Jump to content
OpenSplice DDS Forum
Andoni

Communicate betwwen different subnets

Recommended Posts

Andoni   

Hello,

 

I´m having troubles to communicate two applications using OpenSplice Community Edition V6.4. One application is on a server (IP Address: 10.1.0.1 with Subnet mask: 255.255.255.0) and the other is on a different PC on another subnet (IP Address: 10.1.4.80 with subnet mask: 255.255.255.0). Is there any configuration that allow my apps to communicate?

 

I send attached the ospl.xml used in both apps.

Thank you in advance.

Best regards.

ospl.xml

Share this post


Link to post
Share on other sites

I suspect that there's an issue with multicasting being allowed between your subnets.

 

You could perhaps try and set-up DDSI not to use multicast (AllowMulticast=false)  and explicitly specify the peers under Discovery/Peers/Peer

Share this post


Link to post
Share on other sites

Hi Andoni

 

Did you get this working?  If you do want to work with multicast, maybe check that the network interface has multicast enabled?  Also if the machines have multiple interfaces check that the right one is being selected. See <NetworkInterfaceAddress> in the DDSI2Service part of the XML config where you can set that.

 

James

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×