Jump to content
OpenSplice DDS Forum
Thangaraj

Code Coverage of DDSPublisher.java using EMMA

Recommended Posts

Hello All,

 

I am working in Linux platform ,implementing Opensplice DDS with Java using Eclipse as IDE. Publishesr and Subscribers of main classes are getting executed .Currently working in code coverage part using the tool EMMA .I have created the build file using ant script and created the targets for EMMA,At present 'm facing issue as mentioned below,

This is the content at console:

 

[emmajava] # A fatal error has been detected by the Java Runtime Environment:

[emmajava] #

[emmajava] # SIGSEGV (0xb) at pc=0x00f3a97a, pid=3580, tid=2472213360

[emmajava] #

[emmajava] # JRE version: 6.0_20-b20

[emmajava] # Java VM: OpenJDK Client VM (19.0-b06 mixed mode linux-x86 )

[emmajava] # Derivative: IcedTea6 1.9.1

[emmajava] # Distribution: Custom build (Wed Oct 13 22:53:35 UTC 2010)

[emmajava] # Problematic frame:

[emmajava] # V [libjvm.so+0x20b97a]

[emmajava] #

[emmajava] # An error report file with more information is saved :

hs_err_pid3580.log

 

The error report is been attached..I would like to know is ,how to use the Opensplice DDS with EMMA coverage ?Should i wanna change any of the configurations ?Finally is it possible to make code coverage in DDS implementation ? If any body else is aware about this issue, please guide me to proceed it..Thanks in advance...

hs_err_pid3580.log.txt

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×