Jump to content
OpenSplice DDS Forum

Search the Community

Showing results for tags 'network connectivity'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • About OpenSplice DDS
    • News and Events
    • Site Feedback
  • Using OpenSplice DDS
    • General
    • Troubleshooting
  • Understanding OpenSplice DDS
    • OpenSplice DDS Slideshows
    • OpenSplice DDS Movies
  • Community
    • Project: SIMD
    • Project: CamelOS
    • Project: DDS Touchstone
    • Project: RESTful DDS
    • Mac OS X

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Company

Found 1 result

  1. Dear all, I´m a newbie regarding DDS so apologies if these questions are too obvious for all of you. I started using OpenSpliceDDS one week ago and I am running the examples that are provided in the zip file that is obtained from the website for Linux distributions. There are several examples to study and execute, and I am particularly interested in NetworkPartitions. While I have been able to execute it without using the instructions (compiling Chatter and MessageBoard and executing them after setting the environment variables present in release.com), I was wondering how could I create a unicast connection between the two entities that are shown in the example, which is something that I have failed to do. I have tried two solutions: 1. Exporting the network1.xml configuration file present in the example (as said in the instructions, export OSPL_URI=file://$OSPL_HOME/examples/dcps/NetworkPartitions/etc/network1.xml). It did not work. 2. Modifying the configuration file ospl.xml located in /home/[path]/HDE/x86.linux/etc/config in the general properties part (changing AllowMulticast to false, EnableMulticastLoopback to false and NetworkInterfaceAddress to my IP for local tests). It did not work either. <General> <NetworkInterfaceAddress>AUTO</NetworkInterfaceAddress> <AllowMulticast>true</AllowMulticast> <EnableMulticastLoopback>true</EnableMulticastLoopback> <CoexistWithNativeNetworking>false</CoexistWithNativeNetworking> </General> What should I do to create the unicast connection? For this example I already know the IP addreses (or address if requested locally) that will be used in the communcation. Kind regards.
×