Jump to content
OpenSplice DDS Forum

Search the Community

Showing results for tags 'multicast'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • About OpenSplice DDS
    • News and Events
    • Site Feedback
  • Using OpenSplice DDS
    • General
    • Troubleshooting
  • Understanding OpenSplice DDS
    • OpenSplice DDS Slideshows
    • OpenSplice DDS Movies
  • Community
    • Project: SIMD
    • Project: CamelOS
    • Project: DDS Touchstone
    • Project: RESTful DDS
    • Mac OS X

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Company

Found 3 results

  1. Hello, I am trying to set a Linux-based device running OSPL with promiscuous mode at its ethernet interface, but I do not want to be overflown with data from the IP network the device is located in, as it seems that malfunction when it happens. I know that I can set promiscuous mode in the rc.local file of /etc, but afterwards I guess I should set a filter for traffic that allows DDS data transfer but no other kinds of information. My question is: Is there any other IP address, or IP range of addresses, that should be taken into account, aside from the IP used by DDS for multicast communciations (239.255.0.1)? Regards.
  2. rodro_jesus

    DDS-based VPN not sending data

    I am trying to set a VPN where there are two machines running DDS implementations in each side. However, although everything seems to be fine at the network layer (both machines can ping each other with the VPN IP addresses) I see no topics been matched, and therefore if I try to transfer information from one machine to the other nothign happnes. If I try to run the two pieces of code locally, they work and topics are interchanged with no issues at all. I believe that it could be related to DDS requiring multicasting (or the lack of), but I have tried to add multicast at both machines (ip route add 224.0.0.0/4 dev tun0 first, route add 239.255.0.1/32 dev tun0 afterwards) but still nothing happens. I have Ubuntu 14.04 as the operating system in both machines. OpenSpliceDDS implementation running is V6.4.14.
  3. Hello, I try to configure OpenSplice to perform discovery with multicast and then data transfert with unicast. I’m using Networking service but I still haven’t found a satisfying configuration. The configuration I’m using is the following: <OpenSplice> <Domain> <Name>ospl_sp_ddsi</Name> <Id>0</Id> <SingleProcess>true</SingleProcess> <Description>Multicast discovery</Description> <Service name="durability"> <Command>durability</Command> </Service> <Service name="cmsoap"> <Command>cmsoap</Command> </Service> <Service name="networking"> <Command>networking</Command> </Service> <Role>PICS</Role> </Domain> <DurabilityService name="durability"> <Network> <Alignment> <TimeAlignment>false</TimeAlignment> <RequestCombinePeriod> <Initial>2.5</Initial> <Operational>0.1</Operational> </RequestCombinePeriod> </Alignment> <WaitForAttachment maxWaitCount="100"> <ServiceName>ddsi2</ServiceName> </WaitForAttachment> </Network> <NameSpaces> <NameSpace name="defaultNamespace"> <Partition>*</Partition> </NameSpace> <Policy alignee="Initial" aligner="true" durability="Durable" nameSpace="defaultNamespace"/> </NameSpaces> </DurabilityService> <TunerService name="cmsoap"> <Server> <PortNr>Auto</PortNr> </Server> </TunerService> <NetworkService name="networking"> <Channels> <Channel enabled="true" name="Reliable" reliable="true"> <PortNr>53400</PortNr> </Channel> <Channel enabled="true" name="BestEffort" reliable="false"> <PortNr>53410</PortNr> </Channel> </Channels> <General> <NetworkInterfaceAddress>eth0</NetworkInterfaceAddress> </General> <Partitioning> <GlobalPartition Address="225.0.0.1"/> </Partitioning> <Discovery Scope="PICS" enabled="true"> <PortNr>3369</PortNr> </Discovery> </NetworkService> </OpenSplice> With this configuration, it seems that the data are sent twice, once to the multicast address (what I’d like to avoid) and once to the unicast address, which badly impacts the transfert time. Could you tell me what I’m doing wrong? Thank you very much in advance!
×