Jump to content
OpenSplice DDS Forum

Search the Community

Showing results for tags 'configuration'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • About OpenSplice DDS
    • News and Events
    • Site Feedback
  • Using OpenSplice DDS
    • General
    • Troubleshooting
  • Understanding OpenSplice DDS
    • OpenSplice DDS Slideshows
    • OpenSplice DDS Movies
  • Community
    • Project: SIMD
    • Project: CamelOS
    • Project: DDS Touchstone
    • Project: RESTful DDS
    • Mac OS X

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Company

Found 4 results

  1. Hello, I already posted this question in the general discussion section but maybe posting it here is more appropriate. I have two programs, one using OpenSplice 6.7.1 and the other using OpenDDS 3.10. They are both using rtps as protocol, but they are not communicating. They are both using the same domain id and the destination port is the same for both programs (I verified using wireshark). I don't know if I am doing anything wrong with the config... I am using the basic config for OpenDDS and for OpenSplice I used the provided ospl.xml after changing the domain ID. Here are my config files. For OpenDDS: [common] DCPSGlobalTransportConfig=$file DCPSDefaultDiscovery=DEFAULT_RTPS [transport/the_rtps_transport] transport_type=rtps_udp For OpenSplice: <OpenSplice> <Domain> <Name>ospl_sp_ddsi</Name> <Id>223</Id> <SingleProcess>true</SingleProcess> <Description>Stand-alone 'single-process' deployment and standard DDSI networking.</Description> <Service name="ddsi2"> <Command>ddsi2</Command> </Service> <Service name="durability"> <Command>durability</Command> </Service> <Service name="cmsoap"> <Command>cmsoap</Command> </Service> </Domain> <DDSI2Service name="ddsi2"> <General> <NetworkInterfaceAddress>AUTO</NetworkInterfaceAddress> <AllowMulticast>true</AllowMulticast> <EnableMulticastLoopback>true</EnableMulticastLoopback> <CoexistWithNativeNetworking>false</CoexistWithNativeNetworking> </General> <Compatibility> <!-- see the release notes and/or the OpenSplice configurator on DDSI interoperability --> <StandardsConformance>lax</StandardsConformance> <!-- the following one is necessary only for TwinOaks CoreDX DDS compatibility --> <!-- <ExplicitlyPublishQosSetToDefault>true</ExplicitlyPublishQosSetToDefault> --> </Compatibility> </DDSI2Service> <DurabilityService name="durability"> <Network> <Alignment> <TimeAlignment>false</TimeAlignment> <RequestCombinePeriod> <Initial>2.5</Initial> <Operational>0.1</Operational> </RequestCombinePeriod> </Alignment> <WaitForAttachment maxWaitCount="100"> <ServiceName>ddsi2</ServiceName> </WaitForAttachment> </Network> <NameSpaces> <NameSpace name="defaultNamespace"> <Partition>*</Partition> </NameSpace> <Policy alignee="Initial" aligner="true" durability="Durable" nameSpace="defaultNamespace"/> </NameSpaces> </DurabilityService> <TunerService name="cmsoap"> <Server> <PortNr>Auto</PortNr> </Server> </TunerService> </OpenSplice> Any help is appreciated! Thanks !
  2. Hi, The documentation for `DomainParticipantFactory.create_participant(...)` says this about the `domainId` parameter: So does that mean you cannot choose a domain ID which is not in the configuration file? Is there some other way to create a participant in a domain with an ID that is chosen without changing a configuration file? In our use case we'd like to set the `domainId` based on an environment variable. This is generally useful, but it is specifically useful for to scenarios like running tests in parallel in different domains to avoid cross talk. Thanks,
  3. Hi, I am having difficulties with DDS configuration. I have a following set up. Two HF Radios. Each radio is connected to PC through Ethernet cable. Latency of standard windows command line ping is about 2.5 seconds. MTU of HF Radios is 976 bytes. First PC had an IP address set to 10.0.10.15 and a second PC had an IP address set to 10.0.11.55. HF Radios has a routing capability, so packets send from first PC are properly routed to second PC and vice versa. HF radios have set static routed multicast IP 239.255.0.1. I ran a RoundTrip example from Community version of OpenSplice v6.4 example folder build for win32. I configured a DDS according to the best of my knowledge (a configuration file ospl.xml is attached) but I was not able to get the working example. I have also attached a snap shot from Wireshark, which shows that there is heavy communication between DDS applications (mostly heartbeats and acknacks) that leads to saturation of communication channel. I am aware that it is possible to configure channel properties (DataBandwidthLimit) within DDSI2E Service, but unfortunately this service is not available within community version. But still I am convinced that it is possible to configure DDS in such way that heartbeats and acknacks are not sent so often (I am aware of implication of that – slower reaction to changes). Could you please review and update the attached ospl.xml so I can run a RaondTrip example in my environment. I think that it could be interesting for other OSPL DDS users as well to have an example configuration for an environment with constrained resources (low bandwidth and lossy channels). Thank you. Pavel ospl.xml
  4. Hi ! I'm pretty new to using OpenSplice and I've been in difficulties for quite a long time ... I've solved some, I still got two problems ... and there's one for which I'd reallly love some help because I'm quite lost ... I'm trying to execute the PingPong exemple from OpenSplice. So here's what happens : --------------------------------------------------------------- In [PingPong Folder] : "sudo make" Compiling pingpong.idl with SPLICE IDL Compiler [...] make: /bin/idlpp: Command not found make: *** [bld/pingpong.cpp] Error 127 --------------------------------------------------------------- I thought I had problems with my environment variables in /etc/bash.bashrc , but I've checked multiple time, they seem good ! Here they are : --------------------------------------------------------------- # OSPL OSPL_HOME="/home/xaltar/PrismTech/HDE/x86.linux2.6" OSPL_TARGET=x86.linux2.6 PATH=$OSPL_HOME/bin:$PATH LD_LIBRARY_PATH=$OSPL_HOME/[/font][font=arial]lib:$LD_LIBRARY_PATH CPATH=$OSPL_HOME/include:$[/font][font=arial]OSPL_HOME/include/sys:$CPATH OSPL_TMPL_PATH=$OSPL_HOME/etc/[/font][font=arial]idlpp OSPL_URI=file://$OSPL_HOME/[/font][font=arial]etc/config/ospl.xml CLASSPATH=$CLASSPATH:$OSPL_[/font][font=arial]HOME/jar/dcpssaj.jar export OSPL_HOME OSPL_TARGET PATH LD_LIBRARY_PATH CPATH OSPL_TMPL_PATH OSPL_URI CLASSPATH --------------------------------------------------------------- Well, if you happen to know how I could make that work, I'd be really grateful ! Thanks !
×