Jump to content
OpenSplice DDS Forum

Search the Community

Showing results for tags 'DomainParticipant'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • About OpenSplice DDS
    • News and Events
    • Site Feedback
  • Using OpenSplice DDS
    • General
    • Troubleshooting
  • Understanding OpenSplice DDS
    • OpenSplice DDS Slideshows
    • OpenSplice DDS Movies
  • Community
    • Project: SIMD
    • Project: CamelOS
    • Project: DDS Touchstone
    • Project: RESTful DDS
    • Mac OS X

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Company

Found 3 results

  1. Hello, i have a problem with DDS Community Edition 6.4.1 on Windows. I created a programm, which use DDS, as a library. If I use this library on linux with DDS Community Edition 6.4.1 it works fine. On Windows i get the error that a domain_ participant can’t be created. Both times i use the standard ospl config. I attached both log files to this post. Best regards, Dennis ospl-error.txt ospl-info.txt
  2. I am not able to run the release version of either the examples or our own code built by Visual Studio 2010. A minimum required to get the error is the following code: #include "dds/dds.hpp" int main() { dds::domain::DomainParticipant dp(0); return 0; } When I try to run this in Debug mode, I get the error: Unhandled exception at 0x00823456 in DDS_MinimalTest.exe: 0xC0000005: Access violation reading location 0x00000004. Everything works fine in release mode, so I guess the environment variables are ok. Does anyone have an idea about what can cause this?
  3. Hi ! I'm trying to get a DomainParticipant build, however, I got a very annoying error I'm fighting with since some time. So I came here as I really am out of solution for my problem ... I got the following code : DDS::DomainParticipantFactory_ptr dpf = DDS::DomainParticipantFactory::get_instance(); const char* domain = "file://home/xaltar/PrismTech/HDE/x86.linux2.6/etc/config.ospl.xml"; DDS::DomainParticipant_var dpv = dpfp->create_participant(domain, PARTICIPANT_QOS_DEFAULT, NULL, 0); if(dpv.in() == NULL) { std::cout << "\nIsNull" << std::endl; } else { DDS::DomainParticipantFactory_var dpfv = DDS:DomainParticipantFactory::get_instance(); } The problem is that my Domain Participant Var is null, and I can't get anything from it. When I get the instance of the Domain Participant Factory Var, I got an error of "CORBA::NO_IMPLEMENT". And I can't help why ... Do you happen to know ?
×