Jump to content
OpenSplice DDS Forum

igoroya

Members
  • Content count

    1
  • Joined

  • Last visited

About igoroya

  • Rank
    Member

Profile Information

  • Company
    Humboldt University Berlin
  1. Dear OpenSplice team and users, I am trying to compile Touchstone in our Linux 64 bit machines in order to evaluate id OpenSplice DDS performance. OpenSpliceDDSV5.4.1-x86_64 seems correctly installed in the system, and the examples working. The environment variables were sourced before trying to compile. The details of the setting are: Distro: Scientific Linux SL release 5.6 (Boron) Architecture: x86_64 gcc version 4.1.2 The compilation of the java module is successful, but not cpp module, and moreover, the c "tools" module gives the warnings like /usr/bin/ld: warning: i386 architecture of input file `objs/g++.4.1.2/touchstone.o' is incompatible with i386:x86-64 output the cpp mobule crashes with: ddshelp/cpp/DDSError.cpp:70: error: expected constructor, destructor, or type conversion before '&' token gmake[1]: *** [objs/g++.4.1.2/DDSError.o] Error 1 And when trying to execute a "tools" executable, for example "recorder" a segmentation fault is returned. I tried with both OpenSpliceDDS and posix abstraction implementations, but it did not helped. I would appreciate any advice that could help me to solve this problem. Thanks in advance, Igor.
×