Jump to content
OpenSplice DDS Forum

cammishs

Members
  • Content count

    9
  • Joined

  • Last visited

About cammishs

  • Rank
    Member

Contact Methods

  • Website URL
    http://www.prismtech.com

Profile Information

  • Gender
    Male
  • Location
    UK
  1. Hi, This doesn't sound like something we would expect. Have you tried with the latest opensource version 6.3? If you still get the issue can you give some more about the problem, your ospl.xml file, what operating system, etc. Thanks, Steve
  2. cammishs

    Windows build of OpenSplice V6.3.130716OSS

    Marianne, Thanks for the solution. We've got an update coming soon so we'll sort this out in that update. Thanks, Steve
  3. cammishs

    Year 2038 Problem

    Orhan, This is indeed a well known issue that has been debated at the OMG. The OMG spec will address this issue in a future update as it does use 32 bit time. This is tracked in PrismTech's defect system under ospl-605.
  4. cammishs

    IDL generates wrong code using C#

    Andy/Brian, Thanks for the discovery of this issue/confirmation of problem. The next step is to report the issue on the bugzilla page. See the info here - http://www.prismtech.com/opensplice/opensplice-dds-community/community-interaction/bug-reporting That way we'll consider the issue with others (community and commercial) as part of the OpenSplice DDS Development Change Control Board and prioritise appropriately. Steve
  5. cammishs

    IDL generates wrong code using C#

    Andy/Brian, Thanks for the discovery of this issue/confirmation of problem. The next step is to report the issue on the bugzilla page. See the info here - http://www.prismtech.com/opensplice/opensplice-dds-community/community-interaction/bug-reporting That way we'll consider the issue with others (community and commercial) as part of the OpenSplice DDS Development Change Control Board and prioritise appropriately. Steve
  6. cammishs

    Security/Encryption

    Encryption is available in the secure networking service which is part of the Enterprise edition. The description is: "A Security plug-in for the real-time networking is also available which while maintaing real-time and high-performance messaging, ensures data authentication, integrity and confidentiality, while also providing the ability to control access rights." If you would like access to this then please request a secure networking service evaluation from info@prismtech.com.
  7. cammishs

    Version 5.2.0 and Version 5.4.1 issue

    Hi Matt, 5.2 and 5.4 won't communicate. Here's a section from our release notes that will explain why: Switching to the next OpenSplice DDS version OpenSplice DDS uses a versioning policy, which reflects the severity of the changes applied. The OpenSplice DDS version consists of 3 digits: major, minor and maintenance (in that order). Additionally, there may be patch releases made available for customers with appropriate support contracts. The changes that can be expected are: - Major: typically contains changes and/or additions to the DDS API either syntactic and/or behavioral. These releases are always accompanied with a migration guide detailing the DDS API changes and in case of behavioral changes it contains recommendations (if possible) on how to realize the old behavior. Actions to take: Application code has to be adapted in case the application uses methods that have been changed syntactically or when the behavior has changed. Install the same OpenSplice DDS version on all your nodes. Do not mix versions as the wire protocol might not be compatible. Re-generate the code generated by the OpenSplice DDS IDL preprocessor and DLRL Code Generator. Consequently you have to re-compile the generated code. Delete the persistent store. - Minor: contains changes in generated code and/or the wireprotocol and requires the following actions: Install the same OpenSplice DDS version on all your nodes. Do not mix versions as the wire protocol might not be compatible. Re-generate the code generated by the OpenSplice DDS IDL preprocessor and DLRL Code Generator. Consequently you have to re-compile the generated code. Delete the persistent store. - Maintenance: contains bugfixes only and is made available on standard platforms. It is compatible with any previous version of OpenSplice DDS with the same major and minor version number. - Patch: contains specific bugfixes for specific platforms only and is compatible with any previous version of OpenSplice DDS with the same major, minor and maintenance version number. A patch release is identified by a "pxx" version where xx is an incremental patch number after the maintenance release digit. Steve
  8. cammishs

    OpenSplice Community Edition 5.3

    Emilio, We'll be releasing the 5.3 opensource version sometime in late September. You'll be able to get access to 5.3 earlier than that by taking an evaluation of a commercial edition. These will be posted next week to the download pages. Steve
  9. cammishs

    OpenSplice DDS PowerTools

    Hi, As you are starting its probably best to start with the latest versions of OpenSplice and PowerTools. PowerTools does require a license to work, thus please contact technical-support@prismtech.com and they'll be able to get you up and running quickly. Hope that helps, Steve
×