Jump to content
OpenSplice DDS Forum

alyshehata

Members
  • Content count

    1
  • Joined

  • Last visited

About alyshehata

  • Rank
    Member

Profile Information

  • Company
    NASA
  1. alyshehata

    Using Unity3d with OpenSplice

    Hi. I've been able to use OpenSplice successfully to communicate between a Microsoft Kinect and a subscriber app. However, I would like to move this subscriber app from a standalone app, to Unity3d. This involves adding the .dll references. However, Unity3d uses Mono .Net 3.5 (which VS recognizes as .Net 2.0) which seems to be incompatible with OpenSplice. Is there any way to resolve that problem? The error messages I'm getting when building the project is as follows Warning 1 The primary reference "ddsapihelper" could not be resolved because it was built against the ".NETFramework,Version=v4.0" framework. This is a higher version than the currently targeted framework ".NETFramework,Version=v3.5". Assembly-CSharp-vs Warning 2 The primary reference "ddsapihelper" could not be resolved because it has an indirect dependency on the .NET Framework assembly "mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" which has a higher version "4.0.0.0" than the version "2.0.0.0" in the current target framework. Assembly-CSharp-vs Error 3 Metadata file 'f:\Unity\Demos\DestroyedCity\Assets\Plugins\dcpssacsAssembly.dll' could not be opened -- 'Error importing module 'dcpssacs.netmodule' of assembly 'f:\\Unity\Demos\DestroyedCity\Assets\Plugins\dcpssacsAssembly.dll' -- The system cannot find the file specified. ' F:\\Unity\Demos\DestroyedCity\CSC Assembly-CSharp-vs
×